Mucro tonic morph slider

boudin boudin70 views8 posts
  • Users avatarboudin boudin

    I noticed Micro-tonic morph slider is stuttered with Waveform 10 on OSX.
    Can this be improved ?

  • Users avatarMagnus Lidström

    I just tried to reproduce this with both the AU and the VST (which one are you using?) but the only thing I found is that if you already have automation on the morph slider it will flicker if you drag it simultaneously. Is this what you mean?

  • Users avatarMagnus Lidström

    Btw, I just double-checked and verified that Microtonic does indeed send "beginEdit" and "endEdit" properly. I am not sure why Waveform disregards those and continues to update the parameter while the user is dragging the slider. I'd classify that as a bug.

  • Users avatarfrédéric Henrion

    I use vst with no automation on the morph slider.
    Do you mean a Waveform or Microtonic bug ?

  • Users avatarMagnus Lidström

    Could you maybe upload a project where this happens?

    The bug in this case would probably be Waveforms. Normally the host would suspend automation while the user drags a slider, as indicated by the "beginEdit" and "endEdit" functions that I mentioned. Not a biggie though and it doesn't explain your problem since you don't even have automation.

  • Users avatarboudin boudin

    I tried this morning with an empty Waveform project, I added only Microtonic AU version and an empty midi clip in Microtonic track.

    Result, as you can see on the video, the morph slider is stutered and Waveform is frozen for +/- 10 s, after it starts to move again. That's unusable.
    Note : Microtonic works fine on Reaper.

    https://drive.google.com/open?id=1Nsa4OJJ2YkK3O-0o1jt91NVmnGFIKhip

  • Users avatarMagnus Lidström

    So strange. Can't reproduce here. I see some other peculiar behaviour, e.g. if I drag a window quickly Waveform seems to lose the mouse capture and suddenly cease dragging. (This doesn't seem to happen with other plug-ins, but I've never seen it happen to my plug-ins in any other host either.)

    However, no matter how much I drag the morph I can't reproduce the problems in your video. Which version of OS X and Waveform are you using exactly? What kind of Mac?

  • Users avatarboudin boudin

    Waveform 10 (demo version because I will not purchase if Microtonic is not OK)
    OSX 10.11.6
    Imac late 2007 screen 24 '', an old boy but still working well !

You need to be to post a reply

Sign In / Sign Up


First time here? Just enter your current email and sign up.
×