Mictotonic VST crashes but AU ok!

Brian Boyd101 views4 posts
  • Users avatarBrian Boyd

    Hi - trying to use Microtonic in Pro Tools (11) via BlueCat Patchwork. The AU plugin works perfectly, but the VST plugin crashes Pro Tools EVERY time. I've trashed Preferences, reinstalled, you name it, but the VST just won't work. Any thoughts? (apart from "just use the AU then...)
    Thanks!

  • Users avatarMagnus Lidström

    Actually I do have an idea of why this might happen. When we released Microtonic 3 we did something "bold". We decided that it was time to challenge the silly limitation on patch name lengths in the original VST specification. Everyone had already abandoned the limitation of 8 characters only on parameter names so we thought that the 24 characters for patch names was ready to go too. We tested this on all major DAWs (and in some cases communicated the manufacturers) and everything seemed fine.

    Since then there have been one or two cases where minor VST hosts have crashed with Microtonic, but before we've had time to put in workarounds in our code the host manufacturers have solved it on their side. It is usually as simple as increasing a string buffer size somewhere in the code from 24 characters to something a lot more tolerent like 256 or 1024 characters.

    This could explain why the AU is working but not the VST, since AU doesn't have any limitations at all on patch name lengths.

  • Users avatarBrian Boyd

    Great, thanks, I'll increase the buffer size (or just use the AU!)

  • Users avatarMagnus Lidström

    The string buffer size that I mentioned is something that Blue Cat Audio must change in their code. If this is the reason for the crash to begin with. I'm just speculating here.

You need to be to post a reply

Sign In / Sign Up


First time here? Just enter your current email and sign up.
×