Problems with registering

anonymous1 733 views2 posts
  • Users avataranonymous

    Hello. I just purchased Synplant and Microtonic. I was sent the product registration keys. This worked fine for Microtonic, but the key I was given for Synplant appears to be incorrect. My DAW is Logic version 9, and I am running this on a Mac with Snow Leopard (version 10.6.6). Synplant was successfully scanned by Logic, but, after opening and entering the product registration key that I received by e-mail, I keep getting a message that this is incorrect. I have tried 5 times, and I also requested to be sent the registration key again by e-mail (it's the same as the one I've been entering). So what do I do now? Thanks!

  • Users avatarFredrik Lidström

    - Doug Konbrust wrote:
    Hello. I just purchased Synplant and Microtonic. I was sent the product registration keys. This worked fine for Microtonic, but the key I was given for Synplant appears to be incorrect. My DAW is Logic version 9, and I am running this on a Mac with Snow Leopard (version 10.6.6). Synplant was successfully scanned by Logic, but, after opening and entering the product registration key that I received by e-mail, I keep getting a message that this is incorrect. I have tried 5 times, and I also requested to be sent the registration key again by e-mail (it's the same as the one I've been entering). So what do I do now? Thanks!

    Make sure you type in your name and email exactly as it states in the registration email. These are both part of the registration data and must match the key. You can copy the text from the email and paste it in the registration dialog to make sure everything matches.

    I will move this to our support system and handle it by email from here, since registration data is involved that would be unwise to post here. =)

You need to be to post a reply

Sign In / Sign Up


First time here? Just enter your current email and sign up.
×