Issues running in Bidule

Steve Lampert38 views12 posts
  • Users avatarSteve Lampert

    Greetings. I'm on a Macbook Pro running OS X 10.11.6 - I'm trying to run the latest versions of Microtonic, Permut8, and Bitspeek in Bidule 0.9751. All three are loading as dwarfed graphics - the screen shot is of the entire Microtonic window displayed by Bidule - and none of the three products works at all. Just for reference I have no problems running any of my other synths or FX in Bidule on this laptop. Any advice? Please and thank you. Best, Steve

    Screen Shot 2016-08-24 at 2.48.09 PM.png
  • Users avatarMagnus Lidström

    Oh. Looks bad. I used to run Bidule all the time for testing myself, but haven't done so lately. Is this 64-bit? AU or VST?

  • Users avatarMagnus Lidström

    Right, just checked. It has something to do with Retina support in Bidule 32-bit. If you switch Bidule to 64-bit or "Open In Low Resolution" things look much better. I should check if this happens in other Retina-enabled 32-bit hosts too, and possibly contact Plogue.

  • Users avatarMagnus Lidström

    Btw. I have a theory why seemingly only our plug-ins are affected as well. I am using (the extremely deprecated) QuickDraw graphics API in 32-bit mode. Cause that's what draws fastest still(!).

    I assume most plug-ins have switched to CoreGraphics long time ago, also for 32-bit. I can build for CoreGraphics too, but with slightly worse performance. But this is definitely worth looking into for our upcoming builds.

  • Users avatarSteve Lampert

    Thanks very much for the quick response. The plugins are currently installed in Bidule as AU but they look and fail the same when installed as VST; I thought to try that before I bothered you. Thanks again for any help or further info you may come up with. Absolutely love the programs; use them all the time on my desktop (where by the way they run just fine in the same version of Bidule but under OSX 10.7.5, but would love to have them on this (new) laptop of mine. Steve

    BIDULE - 64.png
  • Users avatarSteve Lampert

    I have no clue about this kind of stuff but thought perhaps I should attach this as well.

    Microtonic info.png
  • Users avatarMagnus Lidström

    Just to double-check. If you take info on the Bidule application and either click "Open In Low Resolution" or remove the checkbox on "Open in 32-bit mode" (as in picture below), do the GUI's work as expected for you?

  • Users avatarSteve Lampert

    Open in Low Resolution does work. Open in 32-bit mode does not work. Thank you very much; greatly appreciate the support. Just for future reference will the problem and the solution be the same if I purchase Synplant and/or Echobode?

  • Users avatarMagnus Lidström

    Thanks! Good to know. I meant open in 64-bit by removing the "Open in 32-bit mode" checkmark. The picture was misleading.

  • Users avatarSteve Lampert

    Yep, finally got it thru my thick head ;p Thanks!

  • Users avatarMagnus Lidström

    Btw I just tried the latest 32-bit Ableton Live (which is high-resolution) and everything looked good. So at least this problem doesn't occur in all 32-bit Retina DAWs.

  • Users avatarSteve Lampert

    Good to know, thanks. I normally just run everything in DP or in a Bidule installed in DP. The whole thing of running plugins in stand alone Bidule is for me just a convenience (but an important one) when I'm less concerned with music per se and more concerned with attaining a deeper knowledge of a particular plugin. It's for that reason that I spend a lot of time running Permut8 and one synth at a time in stand alone Bidule. Permut8 is endlessly fascinating.

You need to be to post a reply

Sign In / Sign Up


First time here? Just enter your current email and sign up.
×