MicroTonic receives MIDI, but makes no sound.

Nolan Murillo465 views6 posts
  • Nolan Murillo

    Let me do my best to recall everything that has happened. Here is what I am using:
    Mixcraft 8 on Win8.1 x64
    No MIDI controllers are plugged in. I use an external DAC.

    This has happened twice now. Microtonic will stop making noise. As you can see illustrated in this video:

    YouTube Video

    There is no problem with audio from other sources, and when I first initiate MicroTonic, I can produce sound by clicking on the drum pads (or whatever you call them), but once I apply a MIDI to Microtonic, it stops playing.
    In the video example, I drag and drop the MIDI Pattern to Mixcraft, HOWEVER, if I manually create a new MIDI clip and add the pattern in myself, the effect is just the same.
    I can switch MicroTonic to a different VST plugin, and that new VST plugin will play all the MIDI data on that track, no problems. However, if I change back to MicroTonic, MicroTonic will make no sound.
    I also tried taking MicroTonic to a new project altogether. The result in the same. It seems the whole VST is busted, and not just the project file.

    This first happened when I was just playing around, experimenting with lots of different FX. I thought maybe the sound buffer got overloaded and just crashed the software. However, restarting my host does not fix the problem, and as I said, even a new project doesn't fix it.
    I tried reinstalling Microtonic, and I made sure to install the x64 version, however, the result is the same.

    I'm really at a loss here. Your help is appreciated!

  • Magnus Lidström

    Hi Nolan, I just saw your last email and looked a bit closer on your video here. At the 0:35 you can clearly see how the (B) button goes gray. This suggests to me that the host is responding with 0 on isOutputConnected (and the reason A isn't gray as well is simply a mistake in the UI code as normally the first two outputs of a VST should never be disconnected).

    Although isOutputConnected is marked as deprecated in the VST 2.4 standard it is one of those calls that our plugins and probably many others continue to rely on.

    Of course I may be wrong, but this is my best guess.

    I'll contact the Mixcraft developers and ask them directly.

  • Magnus Lidström

    I've tried to reproduce this problem today with Mixcraft 8 build 418 (looks like you are using a slightly older build 408 btw). "Unfortunately" everything seems to work for me no matter what I do.

    Could you please upload a project file that has this problem on your machine? Attach it here or send it to support@soniccharge.com.

  • Nolan Murillo

    Sorry for the slow reply. I had written a reply to your first response but forgot to post it before I shut down my computer and lost the reply, hahaha.
    Been busy with the day job, so apologies in advance if I have more slow replies.

    Thank you for taking a look at this issue, I really appreciate it since I use Microtonic so often.

    I updated Mixcraft first to see if that resolved the problem. It did not. I also double checked my version of Microtonic too...I learned that you guys put a little easter egg in the software when you keep the "about" tab open long enough. Nice touch.
    I have attached an example project file to this post that has had the bug already happen.
    MicroTonic_ExampleProj.mx8(79.3kB, 778 downloads)

  • Richard Schönfeld

    I have exactly the same problem like documented in the video above in Mixcraft 9 (newest version) today and wonder if in the meantime there had been any solution ?

    If I hit the drum buttons 1-8 like in the video I have sound. If I put another instrument behind Microtonic it produces sound with Microtonic playing.

    But no sound in Microtonic itself when playing, sequencer is working, midi going threw to the following instrument but Microtonic itself is just silent :-(. I thought I miss anything obvious (something you might just have to turn "on") as I am new to Microtonic but could fine nothing in here nore in the manual.


  • Nolan Murillo

    This isn't to down-play your problem, but my solution was to ditch Mixcraft. I got sick of the bugs and poor performance and moved on to using Reaper - a life changing moment. I'm not trying to be reductive here, it's just that I never actually found a solution to this problem.

    I use to evangelize for Mixcraft, but I've found it difficult to support them, and I recommend that you begin the long process of finding a new home for your music creation process (it took me probably 6 months before settling in with Reaper)
    Best of luck, sorry I couldn't provide a more direct answer to the problem.

You need to be to post a reply

Sign In / Sign Up

First time here? Just enter your current email and sign up.
Facebook sign in no longer available. Use the same email to set password and access your account. If you need help, contact us.