All Plugins Broken

James High154 views2 posts
  • Users avatarJames High

    Pretty much ALL sonic charge plugins immediately crash ableton live. Any version.
    This is not a case of noobie doesn't know how to re-scan plugins. This is not a case of "did you install them into the right directory. I've been at this for 10+ years.
    The problem I'm facing is likely relating to deeply embeded registries, temps, etc.

    I own a copy of MicroTonic and BitSpeak.
    I have to wipe the entire ableton appdata user settings files and folders to even have a chance of getting a sonic charge plugin to show up.
    On the few occations where I took the time to reset all prefs and run a full scan, the only plugin that showed up was Bitspeak, and then when I try clicking on that, i get a "Live encountered a serious program error and was terminated, or something to that effect. From then on it'll be disabled or not show up again so as not to crash ableton.

    To make matters worse, I can't even get my liscense file back if I tried. Because the online authenticator wants to direct me to https://soniccharge.com/etc etc etc authentication page. Well the problem there is that I can't reset the idiotic DNS/SL error. I've tried removing any trace of it to try and reset whatever kind of cert or ssl it needs, and you do that by going here: chrome://net-internals
    then going to Delete domain security policies, scroll to the bottom, type the address, then go back and clear all cache and media.
    There' you'll be able to at least get the re-direct from the Registration launcher / program for sonic charge. and it won't give you the https site not secure issue anymore, it'll direct where it's supposed to go. But alas, the program STILL says there was an issue with DNS / SSL settings or something to that effect.

    This is ridiculous that I've had to go to the lengths I've gone to just to try and get this plugin to work.
    Change the way you do registrations or at the least, let older customers like me download their license files manually. I bought Microtonic when it was the ONLY product you had. even before you released bit speak or Synplant.

    Help me out (developer / owner / admin) over here and get microtonic working on my PC again. I'm fairly certain I'm capable of deleting old registries, but I'm not mucking about anymore with this non-sense until I hear back about how this registration issue can be resolved. (or perhaps if I could RUN the vst or any instance of it, I could register it offline with my serial, but that won't happen until something is fixed / updated, etc.
    I'm at the point of just torrenting an older version to see if it doesn't crash live.

    HELP!
    -will no answer to questions such as "have tried uninstalling, re-installing, installing into a new folder, re-installing windows, etc. save yourself the typing. I am way past all that crap"
    fairly certain whatever is crashing Microtonic is related to the current version and ableton Live. The problem is getting it back and running without crash.
    I think the registration issue will be solved once I can actually launch the VST again.

  • Users avatarFredrik Lidström

    Hi,

    Sorry to hear that you are having problems running our plug-ins. First of all. the SSL issue you were experiencing yesterday was my fault. We had a certificate expiring and the server kept on using the old one until I rebooted it, resulting in an out-dated certificate being used and client browsers warning that it was not safe. It has been taken care of already.

    You should be able to sign in and find your manual registration details on your account page:

    https://soniccharge.com/account

    When it comes to the crash in Ableton Live. We use Ableton Live all the time and that should definitely not happen. I will need some more information about your installation;

    • What version of Windows are you using?
    • What exact versions of Live have you tried?
    • Did you try any other host?
    • Are you using any other VST plug-ins, and are they working without any problems?
    • Do you have problems with trial versions of Permut8, Echobode, and Synplant also?
    • Did you install 32-bit/64-bit or both, and which ones are you using?
    • Have you tried an older version of Microtonic? (You can find older versions at the bottom of our download page.)

    And to answer your question about temps and registry. Microtonic preferences is saved in registry and can be found under:
    \HKEY_CURRENT_USER\Software\NuEdge Development\SonicCharge
    (You can safely remove the entire NuEdge Development key if you like)

    Previous authentication files (from the Sonic Charge Authenticator) can be found under your:
    AppData\Local\Sonic Charge\Authorizations
    (You can safely remove this folder as well)

You need to be to post a reply

Sign In / Sign Up


First time here? Just enter your current email and sign up.
×