New max for live device for Microtonic

Oktagon390 views23 posts
  • Users avatarOktagon

    Hi,

    I've just released a Max for Live instrument that embeds Microtonic and exposes it a standalone drum synth optimised for use with Live drum racks and Push. You can get it here:

    https://www.maxforlive.com/library/device/5697/just-the-tonic

    It includes its own patch browser and preset system that you can access directly from the device and on the Push, optimised for speed of preset browsing and parameter tweaking.

    You obviously still need a Microtonic license to use it.

    I also included an example drum that embeds a bunch of the patches shipped with Microtonic. I hope this is ok given that it's all just parameter values that are useless if you don't own Microtonic already.

    If anyone has any thoughts/issues/requests I'd be happy to hear them.

  • Users avatarnomind

    Hey,

    this looks awesome. I was looking for somethig like this. But I don't get how to start/insert microtonic. I loaded the rack and inserted the max for live device, what now?

  • Users avatarOktagon

    Hi,

    thanks for trying it! If everything is working you shouldn't have to do anything to start microtonic. It should be running behind the scenes but is not exposed. If everything is working you should be able to send midi note data to the device and hear a sound. Is that not working?

    If so could I ask if you're on a Mac or Windows and what version of Live you're using? It's possible there are some differences with Max VST initialisation between platforms that I'll need to take into account.

  • Users avatarnomind

    The drumrack and the device are reacting to my commands on push but there is no sound. I'm on windows 10 and using ableton 10.1.

    Edit: I can only control the first 4 parameters with the push, from distortion to panning. To clear up what I did: First I opened the justtonicrack, ableton said that media files are missing, so I inserted the max for live device on every pad on the drumrack.

  • Users avatarOktagon

    Ah that doesn't sound good. So when you say you can only control the first 4 parameters, can you see the other parameters? There should be 4 banks of them.

    It's a little difficult to debug the lack of sound without being on the machine. If you know your way around the Max editor you could try the following...

    Click the little icon on the top right of the device as explained here:

    https://www.ableton.com/en/manual/max-for-live/#25-3-editing-max-for-live-devices

    After a bit it should open up in the Max editor. Then there should be a little blue icon at the bottom of the window that 'unfreezes' the device (for editing) when you click it. Finally there is another little icon also at the bottom that switches out of 'presentation' mode so you can see the actual max patch that makes the device.

    If you scroll right to the bottom you should see a table with a bunch of Microtonic parameters (hopefully). At the top of this table is a little spanner icon. If you click on this it should bring up the Microtonic UI. You can then interact with that as usual. Does clicking the drum buttons make a sound?

  • Users avatarnomind

    I can see the other parameters but can't control them with push. I just opened max and the consoles shows that the microtonic vst wasn't found. Maybe because I got my VST's in another folder?

    opera_2019-09-10_19-53-06.png

    Is this the table of microtonic parameters you mean?
    Max_2019-09-10_19-53-44.png

    Ableton Live 10 Suite_2019-09-10_19-54-28.png
  • Users avatarOktagon

    Ah ok, the VST isn't loading. Probably something to do with where it's looking for the plugin as you say. I'll have to wait until I get home to give more instructions but if you'll bear with me I'm sure we can get this up and running...

  • Users avatarOktagon

    Ok, so if you could try the following that would be really helpful.

    In the Max editor create a new patcher (File->New Patcher). You should get an empty patch with a dotted grid (indicating it's editable).

    Double click anywhere in the window and a box should come up. In it enter the text, 'vst~ Microtonic' and press enter.

    If you now ctrl-double-click on the vst~ object does the Microtonic window pop up?

    Assuming it doesn't, if you hover with the mouse to the left of the vst~ object, a green arrow should appear, which shows a menu if you click it. From that menu, browse to Files->VST.

    In the VST menu should be the names of all of your VST plugins (that Max can see). Is Microtonic in there? How is it named exactly?

  • Users avatarnomind

    Hey, it seems that Max can only see one of all my plugins. I got around 15. They aren't in the default folder of ableton. Thanks for your fast replys, I'm thriled to try your device.

  • Users avatarOktagon

    Interesting, do you know where the Microtonic dll is installed on your system? Where is the one that is detected installed?

  • Users avatarnomind

    They are all in the same folder so I'm not really sure whats going on

  • Users avatarOktagon

    Apparently Max is looking in the folder specified by the Windows registry key 'VstPluginsPath'. That should be where VSTs are installed to. If the Microtonic VST is in there then I'm confused as to why Max can't see it. Could it be a 32/64-bit issue? If you're running Live 10 then I think Max will be 64-bit and so the plugins probably need to be as well.

  • Users avatarnomind

    I created a new folder for all my vsts, so it's not the default one. Im not sure where this default installation path from windows should be. Ableton has a default one but i never saw a vst folder from windows itself. I don't think it's an issue with 32/64 bit, all vst's I use are 64 bit.
    Is it possible to change the place where Max is looking for the VST's?

  • Users avatarOktagon

    I think it looks in the Max search path, as well as the system vst folder specified by the registry key I mentioned. So you could try two things:

    • Open regedit, and search for the VstPluginsPath registry key. This is the system VST path and Max will be looking in there.

    https://support.microsoft.com/en-gb/help/4027573/windows-10-open-registry-editor
    https://www.thewindowsclub.com/search-windows-registry-find

    • The other option is to add your VST folder to the Max search path, using the Options->File Preferences... dialog in Max.

    https://docs.cycling74.com/max5/vignettes/core/file_preferences_window.html

  • Users avatarnomind

    I found the windows default folder and copied my vsts in to it. It seems to work now! But i will try the option you mentioned to add my folder to the max search path. But now Im not sure how to control the other paramerters from my push other than the first four ones. It seems this will be up and running soon, thanks for your help :)

    Edit: I can now control all the parameters from the push. The problem wasn't your device but me. I'm new to the push so I didn't know how to dive deeper into the device paramaters. Awesome work, I know what I will do the next few days :)
    Only thing I have to figure out now is how to browse trough the presets with the push.

  • Users avatarOktagon

    That's great to hear you've got it up and running! I'm still a bit unsure why you're only getting 4 parameters (even on the first bank) though. It should be:

    bank 1 (Main) : PresetSelector, Level, Pan, Mix, EQFreq, EQGain, DistAmt
    bank 2 (Oscillator) : OscWave, OscFreq, ModMode, ModAmt, ModRate, OscAtk, OscDcy
    bank 3 (Noise) : NFilMod, NFilFrq, NFilQ, NStereo, NEnvMod, NEnvAtk, NEnvDcy
    bank 4 (Velocity) : OscVel, OscVelOverride, NVel, NVelOverride, ModVel, ModVelOverride

  • Users avatarnomind

    Hey,It's a bit difficult for me to explain in english but I try to give some feedback. I played a bit around the last days and it worked quiet well , Only problem I had was that sometimes when I wanted to tweak a specific drum sound, I accidentally changed another drum sound because I was still locked into although I already switched. Also I had my problem by switching trough the different banks. And sometimes I couldn't enter the bank 2,3,4 and had to exit and re enter the menu to reach them. This issue put sometimes out of my flow. I'm quiet new with push so I'm not sure if it's just me or a problem with the device. But I'm really happy that you and other are building things like this. I got inspired to build al little drum rack of my own and do some synthesis with the operator. Thanks for putting this out there

  • Users avatarOktagon

    Hi, it's difficult to say if those were device issues or issues with what you have 'focused' on the Push.

    One thing to check is that you're in 'Edit Mode'.

    https://www.ableton.com/en/manual/using-push-2/#29-10-working-with-instruments-and-effects

    In Edit Mode you should see all the device parameter tabs on the bottom row. If you're not in 'Edit Mode' you'll get the tracks/chains instead.

    Regarding the accidentally editing the wrong drum. It can be easy to do that because you have to make sure you have the correct chain on the drum selected, which usually means hitting the pad first. Not sure if that's what's happening here.

    On the other hand if you think this is a bug then I'd love to figure out where it's coming from.

  • Users avatarOktagon

    I've put together a video walkthrough showing how the device works in Live.

    YouTube Video
  • Users avatarTaupe

    Thanks, this looks very useful!!
    I wanna try with my new NI Maschine controller

    But, i cant get the rack to load in ableton 9...

    i have put in in the correct folder, then i cant open in in any way, i tried dragging it on a track or dragging it on the max4life device, nothing happens. sometimes i get the very vague error: 'device is probably broke'

    I re-downloaded several times
    i never used max for live or any max things since quite some time...
    i dont think so because the max4life MT one channel channel thingy worked proper!

    if anyone has any idea for a possible solution??
    I am stoked to make this work...

    good idea this, thanks for your work!

    I hope i get this working: hardware control of Microtinoc is my goal/dream/striving since version negative 1 ;)
    i even tried it wih a yamaha rm1x back in the days (did not work so well)

    have a nice day!

    edit: ii fIgured out it is easy to make my own drumrack from it, but as to how to use it with Maschine, i dont know at this point. I am still figuring out this hard and software ATM...

  • Users avatarDavid Christophere

    So hey,, this looks amazing.. but when I load the amxd file,, no sound,, nada,,, can't figure that out... and when I load the rack it can't find the amxd file... when I point it in the right direction,, still nothing.... maybe you can let me know what's up,,, but sad I can't get this to work...

    and I'm on a Mac Ableton 10.... and max is built in the program...

  • Users avatarDavid Christophere

    edit,,, got the sounds to play.. but definitely the rack doesn't want to load with sounds...

  • Users avatarOktagon

    Hi, sorry you’re both having trouble getting the rack working.

    Unfortunately I think Live is really picky about where the amxd file lives otherwise the drum rack doesn’t find the device. If the amxd is in the expected place it should be found automatically.

    Someone else ran into this problem and posted instructions on the maxforlive.com comments, which I’ll quote here:

    Copy the the files (JustTheTonic.amxd and JustTheTonic Rack.adg) in your Ableton User library. The standard location on a Mac is /Users/[username]/Music/Ableton/User Library/Presets/Instruments/Max Instrument/
    Do not include the JustTheTonic folder, just the files.

    Now from ableton drag the JustTheTonic Rack.adg into your ableton set and it should load the drum rack.

    You can save the files somewhere else and it will still work, but when you load the drum rack it will load with empty chains asking for the amxd file. You need to point to the location where you saved the amxd file. But even if you have done that, the the initial presets don't get loaded somehow. Max makes a copy of the amxd file in the default user library location anyway and references to that one so if you want to alter it, you might get confused because then you have 2 copies of the JustTheTonic.amxd in your library.

    If all is well, the adg file (=drum rack) should find the amxd file (=max file) and that should find your vst (and load 16 instances of it).

You need to be to post a reply

Sign In / Sign Up


First time here? Just enter your current email and sign up.
×