Microtonic keeps forgetting it's registered

B L183 views6 posts
  • B L


    Ever since the big update, Microtonic has been repeatedly forgetting that it's been registered. It does this in an unpredictable manner - sometimes it's fine for days, sometimes I quit and reload my DAW and up pops the dreaded Activate Please screen.

    Certain projects in my DAW seem to have "poisoned" Microtonic instances within them. Loading one of these projects will immediately cause Microtonic to forget it's been registered. What causes them to become "poisoned" is a mystery, and whether this is responsible for all the "forgettings" is likewise a mystery. Either way, only happens with Microtonic, no other VST experiences this behavior.

    Sometimes I can't even click "Authorize" (well, I can, but it doesn't actually register even though it goes through all the motions). I have to manually enter my name/email/serial, and I can't even begin to describe how tiresome that gets after the fourth "whoopsie" in a day. :)

    I'm on Windows 7 with all known OS updates. I don't use any AV software. The old version of Microtonic worked fine after a single registration, no other parts of the chain have been changed since then.

    Other VSTs seem to be fine - just to throw out a few of the more-famous VSTs in case it helps troubleshoot, the registered versions of Serum, Hyperspace, and stuff downloaded from PluginsBoutique all work fine.

    I've tried:

    -Running my DAW in admin mode
    -Manually running the Authenticator in admin mode
    -Redownloading (and of course re-running) the installer
    -Completely deleting the NuEdge information from the registry and re-authenticating (caused my Installed Computers count to go up by 1, but no fix)
    -Various creative cusswords, both muttered AND shouted :)

    This is starting to make me avoid using Microtonic in new projects, because it's such a buzzkill getting ready to work on something and then having to drop everything to play the "No, Microtonic, I Swear You're Registered" game for the countless time. And of course, right now is when I'm most excited to be using Microtonic, thanks to the big update!

  • Magnus Lidström

    This is very unfortunate and ironical because it is exactly the kind of problem that we wanted to fix by rewriting the code that generates the unique machine id. We now use a technique that is recommended by Microsoft. Unfortunately it does not seem to hold up very well.

    Although we have not been able to reproduce the error ourselves we have had one other user who reported similar problems. With his help we managed to pinpoint the error to a specific Windows function that semi-randomly fails on his computer. Just as you describe, it seems to depend on which song he loads into his DAW (he is using FL Studio... you too by any chance?).

    My gut feeling is that some other plugin or perhaps the DAW in itself sometimes leaves Windows in a state where it can no longer successfully answer to our particular system call. Perhaps it is even a Microsoft bug.

    I have devised a workaround fix for this but it needs testing and I would be very happy if you could help us with that. I think I should be able to have a "beta build" ready tomorrow if you are up for it.

  • B L

    Thanks so much for the quick response, Magnus! I would be very, very happy to help test the workaround. You can reach me here or at the email address associated with this account.

    I'm using Jeskola Buzz - esoteric, I know, hahaha. I guess it's reassuring (in a way) that this is happening with other DAWs too, it means it's something that can more likely be fixed! Buzz's VST loader is pretty good (in fact, I find it far more reliable than Audacity or Reaper), though I know in the past it's managed to set various preset values to "NaN", which might be an issue here as well.

    Buzz is free, though unfortunately not open-source. If you're interested I could send you the "poison" .BMX (project) file for testing on your end.

    There's one other VST in the "poison" project that behaves oddly as well (MorphVerb - in this project, and this project alone, trying to add a second instance of MorphVerb will hang everything), so maybe that's the underlying culprit in this instance - though I've had the "deregistration" problem before. This is just the first time I've realized the "poison project" nature.

    And gee, a Microsoft bug? Whoever heard of such a thing! You've got to be kidding me, right? :))

  • Magnus Lidström

    I just sent you an email with the "beta build". Thanks in advance!


    Hello :)

    I arrived here because I got the same issue now.. haha

    Is any solution available?


  • Magnus Lidström

    VRUNO, please try our latest updates. Info here: https://soniccharge.com/forum/topic/1744-autumn-update

You need to be to post a reply

Sign In / Sign Up

First time here? Just enter your current email and sign up.
Facebook sign in no longer available. Use the same email to set password and access your account. If you need help, contact us.