Microtonic 3.3.2 (public beta)

Magnus Lidström318 views23 posts
  • Magnus Lidström

    We have compiled a minor update of Microtonic with improved support for skins. Even though we do not expect any serious problems we will try something new here and call it a "public beta" until we decide to make it official.

    This beta will be most interesting to skin creators because we have made some adjustments to the format of the skin resources. Most notably, pixelSequencer is no longer a requirement and any old PNG's that were encoded with this program need to be decoded or re-encoded to load properly.

    You can find a guide to creating skins for Microtonic 3.3.2 over at our new GitHub for skins:

    https://github.com/fredli74/microtonic-skins

    Downloads for the Microtonic 3.3.2 beta:

    Mac: Sonic Charge Microtonic.dmg(21.1MB, 40 downloads)
    Windows: Sonic Charge Microtonic Win.zip(7.2MB, 42 downloads)

    As soon as we got a nice collection of updated skins we will create an easy-to-use installer for them. This installer will also include the "SkinChooser" script. Until then, please download and manually install this script in the correct location:

    SkinChooser.mtscript.zip(5.08kB, 49 downloads)

    On Mac, this would be /Library/Application Support/Sonic Charge/Microtonic Scripts/. On Windows, the Microtonic Scripts directory is located under the Microtonic installation path under Program Files.

    Skins are expected to be placed in a folder called Microtonic Skins next to the scripts directory (again, under Application Support on Mac and under Program Files on Windows).

    Again, big thanks to all our enthusiastic skin designers. With this update, skinning Microtonic will be even more fun.

  • LarsErik

    Good news! I'm looking forward to trying out the new skin format, especially the color scheme feature.

  • Magnus Lidström

    Did anyone get the SkinChooser to work yet?

  • LarsErik

    - Magnus Lidström wrote:
    Did anyone get the SkinChooser to work yet?

    Oh yes. I’ve been updating my skins to the new standard and it’s been working really great. Got some minor things to fix before you get a pull request.

  • Magnus Lidström

    - LarsErik wrote:
    - Magnus Lidström wrote:
    Did anyone get the SkinChooser to work yet?
    Oh yes. I’ve been updating my skins to the new standard and it’s been working really great. Got some minor things to fix before you get a pull request.

    Most excellent! Waiting with much anticipation.

  • philter

    - Magnus Lidström wrote:
    This beta will be most interesting to skin creators because we have made some adjustments to the format of the skin resources. Most notably, pixelSequencer is no longer a requirement and any old PNG's that were encoded with this program need to be decoded or re-encoded to load properly.

    sounds great! can´t wait to test it

  • LarsErik

    skinChooser.jpg

    I'm saving so many clicks being able to refresh the skin without having to unload/reload the plugin in my vst host. Just lovely.

    Just noticed that the red skin makes Microtonic and Maschine (my vst host) crash and burn. I'm thinking I've got some corrupted png files, perhaps some file that is a psd but is named png or something like that. I'll investigate this, to get the red skin working, and report here what I find.

    With the skins I've made some changes (the matrix editor just like I've mentioned earlier) and yesterday I did new graphics for the morph leds going from circular to vu-meter style. Turned out pretty nice, gives a somewhat better indication on the ratio changes. Some name changes and the green skin is no more, it's to close to the red skin in look and feel. (If someone wants to do a hue-shift on the red skin they can make a green one in 10 seconds.)

  • Manuel Senfft

    Yeah stupid me tried to simply put LarsEriks skins in the skins folder and create my own mtskin file ... didn't work well, since a new PNG format is used, if I understand it correct ... and it just crashed my DAW, haha.

    Looking forward to your updated skins, Lars! Sticking to the non-beta version in the meantime. (-;

    Thanks Magnus, for the update, by the way!

  • philter

    i have some problems, too,
    after installing the update and following the instructions( on win) for the skin chooser script,
    i get 2 new entries in my script menu: "skin chooser" and "skin chooser_main".

    Untitled 1.bmp

    My Host Application was vstHost.
    if i click "skin chooser_main", nothing happens.
    if i click "skin chooser", i get this error message:
    Untitled 2.bmp

    any thoughts?
  • LarsErik

    - philter wrote:
    i have some problems, too,
    after installing the update and following the instructions( on win) for the skin chooser script,
    i get 2 new entries in my script menu: "skin chooser" and "skin chooser_main".

    The Skin Chooser should be in it's folder "SkinChooser.mtscript" under the scripts folder ("Microtonic Scripts" under the program files)

    Double check that the folder "SkinChooser.mtscript" has no subfolders and cointains the js, cushy and schema files.

  • Christian F.

    I got the skin chooser script working, but it doesn't find any skins?

    I put them in a folder called "Microtonic Skins" in /Library/Application Support/Sonic Charge

    Is that not the right path?

    Edit: My bad, I guess the skins have to be updated, I'll be patient then.

    @LarsErik: The dark skin still does it for me, best shit eva!!

  • LarsErik

    - Magnus Lidström wrote:
    - LarsErik wrote:
    - Magnus Lidström wrote:
    Did anyone get the SkinChooser to work yet?
    Oh yes. I’ve been updating my skins to the new standard and it’s been working really great. Got some minor things to fix before you get a pull request.
    Most excellent! Waiting with much anticipation.

    I've done a pull request with my skins now.

    Apart from the obvious update for the new skin format there's small changes and tweaks here and there on all the skins. The most obvious ones are changes to the matrix editors, morph leds and the morph controls. They also all changed their names, something that felt really nice to do mostly because the "silver" didn't look like it was made of silver at all and the zoolander-inspired names felt a bit weird. And yeah, the dark0ne is a good name now that I have a darkTw0 in the works.

  • LarsErik

    - Christian F. wrote:
    I got the skin chooser script working, but it doesn't find any skins?
    I put them in a folder called "Microtonic Skins" in /Library/Application Support/Sonic Charge
    Is that not the right path?
    Edit: My bad, I guess the skins have to be updated, I'll be patient then.
    @LarsErik: The dark skin still does it for me, best shit eva!!

    Good to hear! I'm working on the new dark skin that I hope will be much better looking.

  • philter

    - LarsErik wrote:
    - philter wrote:
    i have some problems, too,
    after installing the update and following the instructions( on win) for the skin chooser script,
    i get 2 new entries in my script menu: "skin chooser" and "skin chooser_main".

    The Skin Chooser should be in it's folder "SkinChooser.mtscript" under the scripts folder ("Microtonic Scripts" under the program files)
    Double check that the folder "SkinChooser.mtscript" has no subfolders and cointains the js, cushy and schema files.

    okay, solved the problem, thx lars eric. my other skins are working fine now,
    but i get this error message (and vstHost crashes) when i try to load one
    specific skin i made.

    Untitled 1.bmp
  • LarsErik

    - philter wrote:
    - LarsErik wrote:
    - philter wrote:
    i have some problems, too,
    after installing the update and following the instructions( on win) for the skin chooser script,
    i get 2 new entries in my script menu: "skin chooser" and "skin chooser_main".

    The Skin Chooser should be in it's folder "SkinChooser.mtscript" under the scripts folder ("Microtonic Scripts" under the program files)
    Double check that the folder "SkinChooser.mtscript" has no subfolders and cointains the js, cushy and schema files.
    okay, solved the problem, thx lars eric. my other skins are working fine now,
    but i get this error message (and vstHost crashes) when i try to load one
    specific skin i made.

    Oh man that's one angry error message right there. I haven't had anything like that happening. Is it happening 100% of the time?

  • Magnus Lidström

    - LarsErik wrote:
    I've done a pull request with my skins now.

    😍 😍 😍

    I've merged this into main. Looking killer!

    One thing I noticed is that your skins are missing customized "tempo" overlays for Microtonic standalone.


  • LarsErik

    - Magnus Lidström wrote:
    - LarsErik wrote:
    I've done a pull request with my skins now.
    😍 😍 😍
    I've merged this into main. Looking killer!
    One thing I noticed is that your skins are missing customized "tempo" overlays for Microtonic standalone.

    Thanks!

    Ah shit, I didn't know there was a tempo overlay..

    I’ll look into it.

  • Magnus Lidström

    - LarsErik wrote:
    - Magnus Lidström wrote:
    - LarsErik wrote:
    I've done a pull request with my skins now.
    😍 😍 😍
    I've merged this into main. Looking killer!
    One thing I noticed is that your skins are missing customized "tempo" overlays for Microtonic standalone.


    Thanks!
    Ah shit, I didn't know there was a tempo overlay..
    I’ll look into it.

    I made a script that shows the tempo overlay in case you do not have access to a Mac for running the Microtonic standalone version.

    TempoOverlay.mtscript.zip(2.35kB, 17 downloads)

  • LarsErik

    - Magnus Lidström wrote:
    - LarsErik wrote:
    - Magnus Lidström wrote:
    - LarsErik wrote:
    I've done a pull request with my skins now.
    😍 😍 😍
    I've merged this into main. Looking killer!
    One thing I noticed is that your skins are missing customized "tempo" overlays for Microtonic standalone.


    Thanks!
    Ah shit, I didn't know there was a tempo overlay..
    I’ll look into it.
    I made a script that shows the tempo overlay in case you do not have access to a Mac for running the Microtonic standalone version.
    TempoOverlay.mtscript.zip(2.35kB, 17 downloads)

    Tack så mycket. Det hjälper.

  • LarsErik

    - Magnus Lidström wrote:
    - LarsErik wrote:
    - Magnus Lidström wrote:
    - LarsErik wrote:
    I've done a pull request with my skins now.
    😍 😍 😍
    I've merged this into main. Looking killer!
    One thing I noticed is that your skins are missing customized "tempo" overlays for Microtonic standalone.


    Thanks!
    Ah shit, I didn't know there was a tempo overlay..
    I’ll look into it.
    I made a script that shows the tempo overlay in case you do not have access to a Mac for running the Microtonic standalone version.

    Now you have a pull request with tempo the overlays for my skins. Thank you for the script, that was a real time saver, and pretty amazing that you took time to help out with stuff like this.

  • Jürgen Preßler

    skin chooser works so far under win10 64bit 202h update.

    but it took me a while to figure out what to do ;D with all the...;D
    so here is the detailled workflow under win10 with ableton10

    user has to manually CREATE both folders INSIDE the main installation-folder, where the user installed the plugin (the dll-files),, because there were none^^, called just like magnus wrote:
    the "Microtonic Scripts"
    and
    the "Microtonic Skins" folders

    INSIDE the scripts folder put the "SkinChooser.mtscript"-folder just like magnus wrote (link for the download in his first post)
    INSIDE the skins-folder put all the skins folders with their respective files inside them (link for the download in his first post):
    "darkOne"
    "tonicA"
    "VintageTonic"
    etc...

    start the daw

    • side info: i needed to go to preferences and put the plugin-sources folder off and on again to initialize a REAL rescan. the rescan fcuntion alone didnt work. after that the plugin folder is foudn by abletons plugin-browser -

    open the microtonic plugin
    go top right corner and click the icon
    the menue that opens shows: "SkinChooser"
    click on it and you have to see a window with all skins available (6 in my case).

    if not, you did something wrong beforehand.^^

    hope that will be helpful not to go apeshit like me after a brief while with nothing working^^.
    staying cool helps thou quite a bit :D. if youre not cool enough and angry go to olas youtube-channel and listen to his metal-chugs til your cool! harharhar

  • LarsErik

    I’ve been using the beta quite a lot, mostly the skin chooser. Works great. Never had anything strange happen apart from the crash I got when I had corrupted files in a skin folder. I’m on Windows 10.

  • electronic drum

    I can confirm that the beta works like a charm here. I'm on Windows 10, too.
    The SkinChooser is great, as is the adjustment to the format of the skin resources (makes it much easier to create or try variations of new skins).
    What I like most about the SkinChooser is that you can change skins "on the fly", so you don't have to close and re-open the plug-in again in order for the changes to take place (this is what some other plug-ins require you to do).
    Thank you Magnus and Fredrik - and Lars-Erik (for your continous work on all those beautiful new skins).

You need to be to post a reply

Sign In / Sign Up


First time here? Just enter your current email and sign up.
×