HiDPI display?

Jeremy G68 views8 posts
  • Jeremy G

    Hi,

    First things first: congrats for these amazing plugins. I've owned Microtonic before, played with Synplant more than once, and just find out that Echobode was the inspiration behind the OP1's CWO, so glad I've found this software counterpart!

    So i'm willing to buy some of them but the demo versions don't seem to have HiDPI GUI. Yet I've read on the forum that a recent update included this enhancement, except for Synplant. Here is what the plugins look like on my machine: you can compare the definition with Bitwig's hi resolution interface behind them:

    Capture d’écran 2021-04-04 080651.png

    Capture d’écran 2021-04-04 080731.png

    Capture d’écran 2021-04-04 080718.png

    (Happy Easter by the way :D)

    Is it just about the demo version or is it the way it is?

    Thanks for your feedback!

  • Fredrik Lidström

    Hey, should work in trial mode as well. Just to make sure the correct version is installed and loaded. Do you have the "Zoom" option under the main menu? I'm not sure if you need to change anything in Bitwig for it to open the plugin in high dpi mode. I do not have it installed, but I read somewhere there should be an option if right-clicking the plugin in the browser?

  • Jeremy G

    Hi Fredrik,
    Thanks for your answer.
    The same thing happen with Ableton Live as well.
    I'm on version 2020.09.29.
    And "Zoom" is set to 100%...
    That's weird, isn't it?

  • LarsErik

    So you want all your plugins to set the zoom level for you?

  • Jeremy G

    Hi LarsErik,

    - LarsErik wrote:
    So you want all your plugins to set the zoom level for you?

    Zoom level is not the issue here, it's the definition of the plugins GUI. See the first post.

  • Magnus Lidström

    With many DAWs, including Live, you need to tell the host that you want the plugin to draw in full resolution. By default, they will use Window's built-in scaling technique to ensure that old plugins draw correctly.

    Look here for how you turn this option on in Live: https://help.ableton.com/hc/en-us/articles/209775985-High-DPI-monitor-support

    In Bitwig you right-click the plugin for this option:


    I will add to this that High-DPI support on Windows is pretty shaky still and some hosts handle this better than others. Microsoft hasn't made this as easy for developers as Apple have.

  • Jeremy G

    Hi Magnus,

    Thanks for your input!

    I don't see the contextual menu under Bitwig when I right click the plugin:

    Capture d’écran 2021-04-13 190031.png

    (Bitwig 3.3.6 here)

    As for Ableton, the auto-scale option is already activated but this GUI is still kind of pixelated.

    But - just to be sure - looking at the screenshots I sent, do you confirm that the plugins GUI should be more detailed? Or maybe I'm just tripping and it's displaying the way it should?!

    It's not a deal breaker but it's not the first time I'm having trouble with plugins GUI on this laptop. For instance, I couldn't get a SSL plugin to display correctly and had to give up, even after a couple of emails with the devs. As you mentioned it, it seems that HiDPI screens and out-of-the-box-peace-of-mind are for Apple users only at the moment!

  • Fredrik Lidström

    No, your screenshots are not high dpi, here are two instances of Bitspeek. Left one added with "Stretch Plug-in Window to Match DPI" disabled, and the right one added with it enabled. Bitwig 3.3.7

    2021-04-13_23h39_54.png

    Make sure you've enabled Plug-in Interface Scaling

You need to be to post a reply

Sign In / Sign Up


First time here? Just enter your current email and sign up.
×