Microtonic on MacBook Pro M1 Max (Monterey)

Sebastian Merk143 views5 posts
  • Sebastian Merk

    Hi, I just installed the Microtonic on my MacBook Pro M1 Max (Mac OS Monterey)... when I opened the standalone plug in the following message showed up:

    Bildschirmfoto 2021-11-19 um 13.48.28.png

    Do you have any idea what to do... the Microtonic is an important part of my Ableton setup:-()

    Thanks!

  • Ploki

    hm, opens fine on my original M1 running monterey.

    it's an identical architecture and same OS so it shouldn't be anything different on the Max

  • Eric Schnorr

    Big Sur and Monterrey fundamentally change how mac is dealing with Permissions, security, and file and installer verification and integrity checks. In fact, this has been moving this way since Catalina. Mojave was the last "old" OS when it comes to this sort of thing. It is very possible that if you have Microtonic already working or perviously installed, and then update to Big Sur or even Monterrey, then it will continue to work. This is due to is already being installed and having checked apple's verification already, so the OS would only check it again if you completely un-installed and then tried to reinstall. Working from before and updating OS is quite different from a "fresh install" of OS, DAW, or plugin. I have seen this behavior on my M1 Mini with Big Sur. Even within Big Sur versions from 11.0 to 11.5.2 to 11.6 there have been some changes. I am not a developer, but I am pretty techy and do some plugin beta testing for other manufactures. I realize re-coding things from scratch can be a heavy lift (especially for ancient dev kits, like the one use for microtonic), but M1 and Big Sur have been out for over a year, so I think there has been ample time for developers to catch up. Some devs are making this a v.X upgrade to help offset needed time and investments.

  • Magnus Lidström

    - Sebastian Merk wrote:
    Hi, I just installed the Microtonic on my MacBook Pro M1 Max (Mac OS Monterey)... when I opened the standalone plug in the following message showed up:

    Do you have any idea what to do... the Microtonic is an important part of my Ableton setup:-()
    Thanks!

    This error has been around for as long as the standalone version has been out, but it has been very hard for me to reproduce. The error code is funny because if you convert it to ASCII it simply says 'nope' (thanks for this informative error Apple).

    My standard question when this error occurs is: do you use an external audio interface? If so, could you please try with built-in audio?

    For the upcoming beta of our plugins (M1 native etc), I have added some workarounds for this error code (basically retrying with different settings). I will post here when the beta is available.

  • Ploki

    Omgh M1 Beta. :D

    Anyway I tried it on both RME and Built in on an M1/Monterey 12.0.1 and i can't get the error to happen

You need to be to post a reply

Sign In / Sign Up


First time here? Just enter your current email and sign up.
×