uTonic Blue Cat's Patchwork / Connector

Ryan Zimmermann61 views2 posts
  • Ryan Zimmermann

    Here's yet another question about multi-channel, which it would appear has been a recurring one for various folks for the last 15 YEARS (wow...just goes to show what an amazing VST uTonic is).

    To start with, my objective is garden variety - one track per channel to further process each channel independently. Let's state for the record that at this point, I am not picky about how this can be successfully accomplished. I'm sure someone will suggest another DAW. Sure, I could do that, but my day-to-day recording is done in PT and those I collaborate with use it.

    I bought Blue Cat's Patchwork specifically to host uTonic in PT. I've found a zillion other uses for it of course, but those zillion other uses aren't why I bought it.

    Running uTonic 3.3 in Patchwork, never could get the multi-out VST to route correctly in Pro Tools trying everything I could think of, I'm on 2022.4 now.

    I picked up Blue Cat's Connector to see if might remedy the problem - meaning I've now given more money to Blue Cat's than I have to Sonic Charge at this point to get uTonic working as intended, and I'm sure we all can agree, that's pretty sad.

    Hopefully I'm just an idiot and that's the only problem with all this, I'd be delighted, and my friends and family's conclusions reaffirmed.

    I've read through the uTonic and Patchwork manuals, I've read the uTonic multi-out PDF, I've been on YouTube. It seems as though other multichannel output plugins hosted in Patchwork seem to behave, but I'm not concerned with any of those at the moment, just this one.

    Here's my latest failed attempt:

    1. Created a stereo Instrument track in Pro Tools. Instantiated Patchwork insert.
    2. Loaded Microtonic Multi vst in a Pre slot.
    3. Enabled pitched midi in uTonic. Audio I/O automatic 16 channels.
    4. Created 8 instances of Blue Cat's Connector in the first parallel chains column.
    5. Set uTonic's midi output to Port A in Patchwork.
    6. Set each of the 8 instances of Blue Cat's Connector input to Port A channel 1-8 respectively.
    7. Set each of the instances of Blue Cat's Connector to Send via Local Host on ports 8081-8088.
    8. Created 8 Mono Instrument Tracks in Pro Tools.
    9. Instantiated one Insert of Blue Cat's Connector per Pro Tools Instrument channel.
    10. Set each of those Connector inserts to Receive from Local Host 8081-8088 respectively.

    Result: Connector does work. However, channel 1 audio is duplicated to each of the 8 channels, midi doesn't make it to the instrument track at all on Record. Looks like this:

    And in Pro Tools:

    Also tried using the regular mode uTonic in Patchwork and routing out using Connector that way - I just get duplicates, no channel separation.

    My previous attempts involved loading the multi-out in Patchwork and loading each of 8 output channels to separate instrument tracks' midi inputs, no luck there getting separate midi tracks.

    Also, I've tried using Patchwork hosting a single instance of uTonic in pitched midi mode as an Insert with 8 aux bus sends to mono instrument tracks - that one didn't work either.

    I can't imagine someone hasn't figured out how to overcome Pro Tools' limitations for uTonic.

    Any suggestions would be highly appreciated, as I've burned many hours trying to sort this out myself, and well, here I am. hlp plz.

  • Ryan Zimmermann

    Removed duplicate topic.

You need to be to post a reply

Sign In / Sign Up


First time here? Just enter your current email and sign up.
×