Synplant not found in Ableton Live

Stefano Müller375 views3 posts
  • Stefano Müller

    Hey Guys,
    I`m having a problem here. I bought synplant and did the whole registration stuff, but now my DAW (Ableton Live 11) can`t find the Plugin. I did put it in my normal plugin folder, reinstalled it multiple times, tried the 32-Bit and 64-Bit (I`ve got 64) version and am now a bit confused and frustrated. EVERY other Plugin shows up no problem. I´m on Windows 10. Best wishes:)

  • AAV

    I am unfamiliar with Live. Using Studio One Professional 5.5.2 x64 latest build in Windows 10 x64 also latest build. Synplant is working great here and scans and is found with my other vsti without problem. Guessing you have a path problem(?) - (ableton is looking somewhere but the vsti is somewhere else (can you look in the ableton vsti directory to see if synplant actually resides there? (Search for Synplant.dll for the 64 bit version)). Are you using other 3rd party vsti's without problem? You really aren't providing a lot of information - ie
    "normal plugin folder" - is that the same folder ableton is scanning? Also is there a blacklisted plugin listing in live?

  • thiiird person

    I need help with this same problem... my microtonic was working as expected in Ableton in Windows 10 before I needed to refresh the OS and reinstall all my software (due to an unrelated wifi driver issue) but ever since I've reinstalled Ableton and started putting my plugins back in place, I'm finding that only Microtonic is missing from Ableton's plugin list.

    I am using the 64 bit version and have tried placing it in my custom VST2 folder, my custom VST3 folder, and in C:/Program Files/Common Files/VST3. All of my other plugins are accounted for and I am keeping close track since it's a reinstall and I've been able to prioritize my favorite and most necessary ones.

    I saw a new tip this morning and tried it out: when I rescanned in Ableton while holding the Alt key, I saw a higher number of VST2s being counted than previous rescan attempts. But after the count, still no Sonic Charge folder in my Plugins sidebar in Ableton.

    Is there a set of manual uninstall instructions somewhere that I could follow? I am wondering if I'm able to fully wipe it from my folders and start over, maybe that would fix it.

    My programmer's instinct is that the new multi-installer has kinks that need to be worked out. Whenever I try to only install microtonic I still get the Multi version included plus bitspeek, echobode, etc dlls in the install folder. When the installer warns me it will delete and re-add plugins it has detected, and I change the install folder, it leaves the other dlls in the old install folder and only moves the microtonic dll.

    I don't know enough about plugins to know whether it's even related - microtonic is a 64 bit VST2, correct? I was only trying it in VST3 folders to be thorough - but I thought the installer weirdness was worth mentioning. Last working version of Microtonic I had was pre 3.1 I believe, one of the standalone installs. (are any of those zips still living in a google drive to try?)

    UPDATE: figured out that VST2 != 32 bit and 64 bit != VST3, then realized I had the sonic charge installer pointed at the VST3 folder instead of the VST2 custom folder in my setup. Moving the 64 bit version of the plugin to my custom VST2 folder is what did it. My Ableton needs the 64 bits to run anything, and then within that category, I needed to recognize both VST2 and VST3 can coexist and I had mislabeled Microtonic in my own thinking.

    So excited to get back into making new sounds!

You need to be to post a reply

Sign In / Sign Up

First time here? Just enter your current email and sign up.
Facebook sign in no longer available. Use the same email to set password and access your account. If you need help, contact us.