Soniccharge plugin installer not working on OS Monterey

Borja Ruiz147 views3 posts
  • Borja Ruiz


    I just bought a new Mac Studio and spent the last couple days installing all my software.
    When opening the Soniccharge installer an error message appears and the installer stops working.

    The error message is:

    The operation couldn’t be completed. ( error -1.)

    Some help would be much appreciated.

  • Fredrik Lidström

    Hi. We've seen this before, and some users solved it by installing all available macOS updates.

    Also make sure you have downloaded the latest multi-installer from 2022-03-21

  • Borja Ruiz

    Thanks a lot Fredrik.

    I've updated the macOS and the SonicCharge installer worked.

    I can finally enjoy Microtonic again!

You need to be to post a reply

Sign In / Sign Up

First time here? Just enter your current email and sign up.
Facebook sign in no longer available. Use the same email to set password and access your account. If you need help, contact us.