Microtonic does not appear in Reaper

Stephen Scott159 views9 posts
  • Stephen Scott

    Hello,
    I downloaded Microtonic from Plugin Boutique after purchasing, went through the installation process, entered the serial number and so forth, everything seemed to work fine.

    However, Microtonic does not appear in my VSTi or VST3i lists of plugins in my DAW, Reaper.

    I tried re-starting the computer, still nothing.

    I then tried uninstalling and reinstalling the app, again everything went smoothly, yet it does not show up in my list of VST instruments in Reaper.

    Looking at the files and folders, I noticed all my other plugins have .dll files, for Microtonic I only see .vst3 files in the Sonic Charge folder within the VstPlugins folder. I don't know if that's a factor.

    For all other VST's I have installed, they just get picked up by Reaper the next time I start it, but the scan doesn't happen for Microtonic.

    Any help with this would be greatly appreciated.

    Thanks,
    Stephen

  • Fredrik Lidström

    Hey Stephen,

    It sounds like the paths got mixed up. During installation you get to pick the folders for VST 2.4 (.dll) and VST 3 (.vst3) files. Make sure you pick the correct paths here so they correspond to the locations you setup in Reaper.

  • Stephen Scott

    Thank you for your input, Fredrik.

    I uninstalled the software, then installed with the vst3 path being:
    C:\Program Files\Common Files\VST3\Sonic Charge
    The files appearing there are
    Microtonic Multi.vst3
    Microtonic.vst3
    And these two now show up in the Reaper VST3i list, but when I select one by adding to the currently selected track, Reaper just closes down.

  • Fredrik Lidström

    What version of Reaper are you using? I'll see if I can test the exact same version.

    You could also try installing the VST 2.4 version, there is basically no benefit from running VST3, unless you have to because it's the only version the host supports. Would be interesting to see if you run into the same problem or not.

  • Stephen Scott

    I am using most recent version of Reaper, 6.80.

    I downloaded both 2.4 and VST3 versions of Microtonic, only the VST3 version appears in Reaper's list of available plug-ins, and selecting Microtonic VST3 still causes Reaper to close, same with Microtonic Multi.

  • Stephen Scott

    I just updated to Reaper version 6.81 this evening, still the same result, it closes the whole program when I click to add Microtonic or Microtonic Multi as a new instrument on a track with a new MIDI item.

    Thanks for any help you can provide, Fredrik.

  • Stephen Scott

    Fredrik Lidstrom wrote: I'll see if I can test the exact same version.

    Have you had an opportunity to test with latest version of Reaper?
    I would prefer to get Microtonic working, but do I need to be requesting my money back from Plugin Boutique? Because I don't see how to get it working. Please let me know.

    Regards,
    Stephen

  • Fredrik Lidström

    I'm not experiencing any problems with Microtonic and Reaper 6.81. I tried both the 32-bit and the 64-bit versions of Reaper.

    Did you download the latest multi-installer (2022-11-25)?



    If you install both vst2 and vst3, like this, you can test them both in your Reaper and see if any of them work (both works for me)

    2023-07-18_22h01_22.png


    Clear cache and rescan if they do not show up inside Reaper.

    2023-07-18_22h02_58.png

    2023-07-19_00h05_21.mp4
  • Stephen Scott

    Fredrik Lidström wrote: Did you download the latest multi-installer (2022-11-25)?

    Ok, I once again uninstalled Sonic Charge from my system, and checked all relevant directories to be certain everything had been deleted.

    I then ran the .exe file in the Sonic Charge Plugins 2022.11.25.zip folder (BTW, while this contains MicroTonic 3.3.4, the download from Plugin Boutique's website has version 3.3.3). I then selected to install Micro Tonic, both VST2 and VST3 versions as you pointed out. I also closed all other programs before running the installer just in case there may be interferance. Installation went smoothly.

    However, when I attempt to open the plugin in Reper 6.81, once again, there is a short pause, and then the Reaper window closes.

    I also tried the clear cache and re-scan as you suggested, as well as using your method of Insert > Virtual instrument on new track... as you did in the video instead of setting up the track and then adding the instrument as I usually approach it but again, Reaper closes down.
    The problem is no longer that Micro Tonic does not show up in Reaper, it just crashes Reaper!

    Just FYI, when I purchased Micro Tonic from Plugin Boutique, I also got D16 Group's Phoscyon 2 in the same purchase. I downloaded and installed Phoscyon 2 and it works in Reaper 6.81 without any issues. i just don't know what to do differently.

    Please let me know what to try.

    Regards,
    Stephen

You need to be to post a reply

Sign In / Sign Up


First time here? Just enter your current email and sign up.
×
Facebook sign in no longer available. Use the same email to set password and access your account. If you need help, contact us.