Synplant 2 VST3 - Error when verify plugins is scanned in FL Studio 21

NextDAW452 views11 posts
  • NextDAW

    The VST3 format of Synplant 2 shows an "Error", when Synplant 2 is scanned in FL Studio 21 (both in the latest release of the DAW and also in their 21.2 beta 3). This is while performing scan for new plugins with verify plugins selected (as is recommended by Image-Line).

    Synplant 2 - VST3 Error - Plugin Scan FL Studio 21.png

    Synplant 2 - VST3 Fail to Load.png

    Note, the VST2 version works fine. Only the VST3 version seems to be effected. 

    System Info:
    Synplant 2.0.0 (268) [VST3]
    FL Studio v21.0.3 (Official Release)
    FL Studio v21.1.99 [build 3803] (their latest Beta)

    Processor 12th Gen Intel(R) Core(TM) i7-12700F 2.10 GHz
    Installed RAM 16.0 GB (15.8 GB usable)
    System type 64-bit operating system, x64-based processor

    DirectX version: 12.0
    GPU processor: NVIDIA GeForce RTX 3060

    Edition Windows 11 Home
    Version 22H2
    Installed on ‎13/‎05/‎2023
    OS build 22621.1848

  • Karschnackelwackel

    Same here. I installed only VST3 and got an error. When I installed vst2+3 I can open Synplant.

  • NextDAW

    Check which version has actually loaded ... It's probably the VST2 one.

    I also installed both VST2 and VST3 versions. Only the VST3 version of the plugin has the error.

    However, my previous projects using Synplant v1 were all saved with the VST3 version. So currently, I am unable to load Synplant in those, since the VST3 can't load in FL Studio.

  • Josh Gemmell

    The VST3 also won't load in Waveform (v12.5.11 on Windows10). Strangely, it loads and validates just fine in the built-in plugin validator.

  • Magnus Lidström

    We have tested with all major hosts, and I just did a fresh install of both FL Studio and Synplant to make sure, and it does work for me. I wonder what is going on here.

    Screen Shot 2023-10-04 at 01.27.58.png

    We did test in Waveform too.

    Did things sort themselves out for you guys, or do we need to look more into this?

  • NextDAW

    - Magnus Lidström wrote:
    We have tested with all major hosts, and I just did a fresh install of both FL Studio and Synplant to make sure, and it does work for me. I wonder what is going on here.


    We did test in Waveform too.
    Did things sort themselves out for you guys, or do we need to look more into this?

    I previously had v1 of Synplant installed and I used the Sonic Charge Multi-installer [2023.10.03] - installing over the top - the installer did inform that it would first uninstall one existing plugin.
    Perhaps, it never managed to fully remove v1? ... I will try to uninstall (and manually delete any residual remnants of v1) and then try to reinstall the newer versions to see if that fixes the issue. And report back here with the results.

  • Fredrik Lidström

    Downloaded v21.1.1 [build 3750]

    I wonder if something went wrong during your installation, like if a file was busy (since Synplant 2 replaces Synplant v1, with the same name).

    My suggestion is that you uninstall, rescan, make sure you have no Synplant at all left in your host. Install again and then rescan.

    Also, Waveform (v12.5.11 on Win 10) is the exact same version I used in my tests, so it should definitely work.

    2023-10-04_01h39_25.png
    2023-10-04_01h40_05.png

    What I found in my tests is that it got hung up on Synplant v1 here as well, I had to remove it from the list before rescanning. You can also just remove all plugins, clear list, and then rescan from scratch.

  • Karschnackelwackel

    I got the error too when I installed only VST3 without uninstalling my old Synplant 1 before.
    Then I have uninstalled Synplant and installed Vst2+Vst3. Now in my plugin manager list it says "Synplant (vst2&vst3)" and it works.

  • NextDAW

    Good news ... VST3 Confirmed to be Working in FL Studio 21 Windows 11

    I completely uninstalled (checking to make sure all remnants of Synplant v1 had been removed, which they had. i.e. no manual deletion was required) and then I reinstalled again using the same Sonic Charge Multi-installer [2023.10.03].

    I then also removed any previous instances of Synplant from FL Studio's saved Plugin Database.

    Then initiated a new check for new plugins again with Verified Scan as previously.

    This time, successfully recognizing and merging both VST2/VST3 formats without any errors. And the VST3 version is now working perfectly.

    The issue must have been due to either/or my previous Synplant v1 not being completely uninstalled, or perhaps even just the remnant thereof within FL Studio's plugin database.

    Either way, this issue is now completely fixed and resolved. Thank you for your confirmation and help.

    VST3 error issue solved by uninstalling and reinstalling and als

    VST3 Confirmed to be Working in FL Studio 21 Windows 11.jpg
  • Josh Gemmell

    I had to uninstall it, clear it from Waveform's plugin list, then re-install and now the VST3 version loads.

  • Darren Jackson

    Quicker than uninstalling / reinstalling, the following worked for me

    Open Windows Explorer to here:

    C:\Program Files\Common Files\VST3\Sonic Charge

    Move Synplant.vst3 to somewhere else e.g. Desktop. Rescan plugins, the vst3 version should disappear. Then move the Synplant.vst3 back into the above folder and rescan again.

You need to be to post a reply

Sign In / Sign Up


First time here? Just enter your current email and sign up.
×
Facebook sign in no longer available. Use the same email to set password and access your account. If you need help, contact us.