Synplant 2 - Genopatch causing PC crash

Aseem Mangaokar375 views16 posts
  • Aseem Mangaokar

    Hi all,
    just downloaded the demo of Synplant 2 to try it out on my PC, running Ableton Live 11.3.11.
    Every time I load a sample into the Genopatch section and hit "generate patch", i'll see the branches develop and then immediately my PC crashes and restarts. I'm going to try it on my M2 Macbook air too because I really like the idea of the plugin. Hopefully it's just a bug that they'll fix with an update.

    Anyone else getting this issue on PC ?
    system spec:
    Ryzen 5950x CPU
    32GB RAM
    Cranborne R8 interface

  • Jason Anderson

    Hi Aseem,

    Genopatch generation seems to be working fine in my Live 11.3 on Win laptop, however it Does require a lot of real-time CPU WHILE generating patch solutions for me as well, however it backs down upon completion and there has been no 'crash' for me. Good luck

    My Windows 10 Home System:
    Intel(R) Core(TM) i7-10750H CPU @ 2.60GHz 2.59 GHz
    Installed RAM 32.0 GB

  • Magnus Lidström

    We actually solved Aseem's problem on Twitter/X yesterday. Short story: never overclock your CPUs guys and gals. 😉

  • Manuel Senfft

    I just started a thread with an idea here: https://soniccharge.com/forum/topic/2499-fr-add-cpu-cap-for-genopatch

  • Daniel Merrill

    I'm having this exact same issue - does anyone know how to resolve it? Windows 10, fully updated, Ableton 11.2

  • EnochLight

    - Daniel Merrill wrote:
    I'm having this exact same issue - does anyone know how to resolve it? Windows 10, fully updated, Ableton 11.2

    Are you overclocking your CPU?

  • Daniel Merrill

    - EnochLight wrote:
    - Daniel Merrill wrote:
    I'm having this exact same issue - does anyone know how to resolve it? Windows 10, fully updated, Ableton 11.2
    Are you overclocking your CPU?

    Thanks for the response, not overclocking at all, and my specs are:
    Intel(R) Core(TM) i7-9750H CPU @ 2.60GHz 2.59 GHz
    32.0 GB (31.8 GB usable)

  • Daniel Merrill

    Wondering if anyone has any solutions for this? I'm literally just unable to use the Genopatch function, it locks up not just Ableton but my entire pc, can't move the mouse, nothing - hard lock, can only restart. Appreciate any help as I'm beyond excited to get into this plugin, I've been waiting many, many years!

  • Fredrik Lidström

    Couple of things you could try out.

    1. Try limiting which cores that Ableton uses.

    Right-click Ableton Live and do "Set affinity". Then remove about half of your CPUs. (You have a 6 core 12 thread CPU correct?)

    2023-10-19_03h10_54.png

    1. Try a different host

    Unfortunately, we don't have a stand-alone version on Windows, but if you could try a different host, and see if you get the exact same result, it would be interesting. If you don't own any other host, a free one or a trial version works fine.

    1. Stress test your CPU

    Try some free utility for stress-testing your CPU. Like HeavyLoad.zip(9.13MB, 104 downloads)
    (Select CPU and Memory testing)

    2023-10-19_03h18_08.png
    2023-10-19_03h19_27.png
    2023-10-19_03h21_23.png
  • Cesare Marionetti

    just an update,my pc is not overclocked my configuration:
    INTEL CORE I9-13900K 5.8 GHZ LGA1700
    MSI PRO Z790-P
    CORSAIR VENGEANCE DDR5 RAM 32GB (2x16GB) 5600MHz CL36
    when I use the Genopatch (100% cpu) or if I modify the synth parameters (osc, filter..) audio glitches are generated and the CPU jumps up.

  • NewLoops.com (Download Synplant 2 Pro Expansion Demo!)

    It only crashes for me when I am also running COD MW2 and using the AI in Synplant! lol

  • Magnus Lidström

    Unfortunately, we cannot reproduce this problem on any of our PCs, and we need your help figuring out what causes system slowdowns (and even total freeze-ups) on some installations.

    One theory I have is that it's due to thermal throttling and possibly even inadequate cooling. Perhaps someone with this problem could download https://openhardwaremonitor.org/ and have a look at the temperatures and CPU clock speeds when Genopatch is working?

    This is a hard nut to crack, and I really want to find a good solution in the upcoming 2.0.1 update.

  • Magnus Lidström

    Another test that anyone with CPU-load troubles could do for me is to download this Genopatch configuration:
    synplantGenopatchConfig.numbstrict.zip(0.87kB, 115 downloads)

    Unzip it and place the .numbstrict file into C:\Program Files\Sonic Charge\Synplant Genopatch\ (replace the file with the same name that is already there). Restart Synplant and see if it makes any difference.

    Thanks in advance.

  • Cesare Marionetti

    Now works fine no glitch after replace a new config file.

  • Magnus Lidström

    - Cesare Marionetti wrote:
    Now works fine no glitch after replace a new config file.

    Interesting. Not an overheating problem for you then. It's not a perfect solution, though, because it is lowering the priority of Genopatch so much that any other process running could potentially grind it to a halt.

    But in your case, it was never about the GUI freezing up, right?

  • Cesare Marionetti

    in fact the gui has always worked for me, my problem was after the analysis was finished the asio started to have clicks.

You need to be to post a reply

Sign In / Sign Up


First time here? Just enter your current email and sign up.
×
Facebook sign in no longer available. Use the same email to set password and access your account. If you need help, contact us.