Failed integrity test Synplant2

Patrik Kindvall1 258 views7 posts
  • Patrik Kindvall

    I get "Integrity Check Failure" after 30 mins . Even though i uninstalled everything and deleted dll and reinstalled.

  • Fredrik Lidström

    That's not good. You say dll. Are you only running the VST2 version? Just want to be sure there's not a VST3 version as well (.vst3 file).

    What host are you running? Does it have a plug-in manager where you can see the exact path of the plugins?

  • Patrik Kindvall

    Hey, Yes I never installed a vst3 only vst2. and i double checked so there is only the vst2 .dll.
    I'm running ableton live. Yes i know the exact path and deleted it but keeps happening anyway.

  • Magnus Lidström

    This is concerning. This error indicates that something might tamper with the binary on your installation. Could you please:

    1. Locate the vst2 Synplant.dll and zip it.
    2. Double-check that there is no Synplant.vst3 in C:\Program Files\Common Files\VST3\Sonic Charge. (But if there is, zip this one too.)
    3. Email us the zipped files (
    4. Delete the found .dll / .vst3
    5. Start Ableton, and make sure that the Synplant plugin is gone (if not, try rescanning plugins)
    6. Reinstall
  • Patrik Kindvall

    I think i found the fault. Apparently it was my antivirusprogram (Avast) that haorded a synplant file. I found it after searching through my harddrive. Couldnt delete it so had to uninstall my antivirus software. Now it works 6 hours + =). Thanks

  • Magnus Lidström

    Oh wow. I am pleased to hear you solved this. Anti-virus programs can be a total pita imho. We will see if there is anything we can do to avoid this issue in the future. Thanks for bringing it to our attention.


    Hello patrick the same thing is happening to me what exactly is the relation between the antivirus and this error and howncan i fix it is there any possible ways i can fix this

You need to be to post a reply

Sign In / Sign Up

First time here? Just enter your current email and sign up.
Facebook sign in no longer available. Use the same email to set password and access your account. If you need help, contact us.