Synplant crashing on Logic Pro

Viktor Vardanyan46 views4 posts
  • Viktor Vardanyan

    Hi !

    Synplant 1 user here. I decided to play around with the Synplant 2 trial and while I loved the new features, I figured I had no use for them so I redownloaded Synplant 1.2.2 again on my Mac to continue using the product I own. This is where my troubles began. For some reason, I haven't been able to successfully open Synplant a single time. If there was a preset loaded from a previous session the sound would play but every time I clicked to open the plugin Logic would just force quit.

    I tried redownloading several times but the same thing keeps happening and I'm honestly not sure why. The versions of my Mac (12.5.1.) and Logic (10.7.5) were not changed before or after downloading Synplant 2.

    Would really appreciate your help in solving this as it's getting pretty frustrating now.
    Thanks!

  • Joey Luck

    The latest version of Synplant v1 is 1.2.6. That is installed with the multi-installer called Sonic Charge Plugins 2022.11.15.dmg

    1.2.2 is from 2015. So I'm guessing that might be your issue?

  • Viktor Vardanyan

    Ah, that explains it. Got it to work.

    Thanks, Joey !

  • Joey Luck

    Great! Glad that's all it was :)

You need to be to post a reply

Sign In / Sign Up


First time here? Just enter your current email and sign up.
×
Facebook sign in no longer available. Use the same email to set password and access your account. If you need help, contact us.