Synplant 2 overwrites Synplant 1, DAW won't load Synplant in any of my old projects

Chevy Ash71 views9 posts
  • Chevy Ash

    Hello, I just recently installed Synplant 2 on my Windows 11 PC with FL 21 and it seems to have messed something up with my original Synplant files. I've always used a genuine Synplant, and I just upgraded to Synplant 2. When I upgraded/updated, it made me uninstall Synplant 1 to install 2. And now that I've done this, all of my projects using Synplant can't load in the plugin Screenshot:

    Screenshot 2024-01-25 201144.png

    This is fatal because 3 of the 4 the songs I'm working on right now use Synplant very heavily...one thing I did notice is that in my plugin database folder for FL, there is no VST3 version of Synplant listed anymore, and when I load my old files, it says that it can't find the VST3 file specifically. I don't have any old projects using the normal VST file to test it on though sadly. I've tried uninstalling and reinstalling a few times, I just can't figure out why it's doing this...I'm really hoping someone on here can help me find some sort of a solution because I really don't want to lose these projects, but I'm starting to lose hope. Any help would be greatly appreciated, and please let me know if you need any more information. Thank you so much.

  • Chevy Ash

    Also, another thing to mention...every time I reinstall Synplant 2, FL makes a "Synplant" and "Synplant_2". "Synplant" comes up with an error any time you open it, while "Synplant_2" opens normally. This also happened when I tried to uninstall and downgrade back to Synplant 1; it became "Synplant_2" and "Synplant" would come up with the same error. Sorry, I forgot to mention that in my initial post. Once again...any help would be greatly appreciated, thank you so much.

    Screenshot 2024-01-25 201736.png

    Screenshot 2024-01-25 201648.png
  • Chevy Ash

    Also, under "Installed" in my plugin database in my FL Studio folder, Synplant isn't listed under the VST3 plugins. So I'm wondering if this could be the issue, or if I'm looking in the wrong place completely...

  • Sun Juice

    There are two Synplant VST plug-ins on the computer, so synplant_2 will appear. You can check the specific location of Synplant and Synplant 2 in plugin manager. Uninstall Synplant 2. Rescan the plugin, then find Synplant in plugin manager, see where it is, delete it, reinstall Synplant 2, and scan the plugin again

  • Chevy Ash

    - Sun Juice wrote:
    There are two Synplant VST plug-ins on the computer, so synplant_2 will appear. You can check the specific location of Synplant and Synplant 2 in plugin manager. Uninstall Synplant 2. Rescan the plugin, then find Synplant in plugin manager, see where it is, delete it, reinstall Synplant 2, and scan the plugin again

    I just tried that...thank you for the suggestion. I deleted every single file on my computer related to Synplant and Sonic Charge, and I'm still having the same issue, sadly...
    I do believe that this has something to do with the VST3 version of Synplant 2. In my plugin database within FL, when I scan for new plugins, it says that there is an error with the "Synplant.vst3" file...and then once again somehow renames the VST file to "Synplant_2" (unless I somehow missed a file somewhere, but I swear I searched my entire PC)...

    Screenshot 2024-01-26 013134.png

    I'm afraid that I'm starting to lose hope the more and more I dig into this :( Going to try to uninstall and reinstall FL Studio now...
  • Chevy Ash

    Well...I guess I'm giving up hope for now, unless anyone has any other suggestions. I deleted all Sonic Charge data on my PC and did a completely clean install on FL Studio, and I'm still having the same issue. Oddly enough, the VST3 version doesn't have an error anymore, so I guess that wasn't the issue like I originally thought. I'll take it as progress, I guess lol

    Also, no, I didn't overwrite the project file or anything on this song, I actually tried it with a few different ones and it didn't work in any of them :/

    Screenshot 2024-01-26 022819.png

    Screenshot 2024-01-26 022554.png
  • Fredrik Lidström

    Hey, if you were using the VST3 version of Synplant v1 previously, it could be related to this issue:

    https://soniccharge.com/forum/topic/2487?~post13089

    When you tried to downgrade to Synplant v1 again, did you download 1.2.6 that is in the Sonic Charge Plugins 2022.11.25.zip Multi-installer? Just double-checking because we did not have a VST3 version prior to that.

  • Chevy Ash

    Thank you for your response Fredrik, I will look into this now! I looked at that topic/thread previously, but I guess I didn't read closely enough...silly me.

    When I downgraded, I believe that I may have installed the previous version before the one that you linked, Sonic Charge Plugins 2022.03.21.zip. I will re-do the process, and install this one just to make sure...thank you very much once again for your response, I will update soon :)

  • Chevy Ash

    It worked! It took me awhile because I still ended up having to reinstall FL completely again. I had to uninstall and delete all Sonic Charge-related files (I think this is something to do with FL, not on your end) and then completely reinstall FL Studio again, but it's working with the 11/25 build of Synplant 1. So, I'm going to save all of the presets I've made within these projects, then upgrade to Synplant 2. Thank you both so much for your help...this means so much to me. Synplant forever!

You need to be to post a reply

Sign In / Sign Up


First time here? Just enter your current email and sign up.
×
Facebook sign in no longer available. Use the same email to set password and access your account. If you need help, contact us.