Synplant keeps asking for registration

Mike Bosch1 499 views3 posts
  • Users avatarMike Bosch

    Hi,

    I have a problem with Synplant. For some reason Synplant keeps asking for the registration every time I open a project that contains Synplant in Ableton or any other DAW I use.

    It says that my three weeks demo have expired, but I bought it and registered it and first it was working fine. Does anyone have this issue or knows about how to solve the problem?

    I love synplant, but now I am at the point of turning my back to it, since I am unable to use it properly.

    Mike Bosch

  • Users avatarFredrik Lidström

    Hi Mike,

    Now as far as I know, Mavericks should not try to sandbox Ableton. Unless they do something other evil, my best guess is that the user you are running Ableton as, does not have sufficient rights to open/write your preferences.

    First of all you can run Apples "Disk Utility" and run a "Repair Permissions" on your hard-drive, to make sure nothing broke in the upgrade.

    Next, go to your Library in your home folder. It is hidden in the Finder by default, so you need to use the menu Go -> Go to folder... and enter ~/Library (do not miss the ~). Now down inside Preferences/ByHost you should find a file starting with "com.soniccharge" and ending in ".plist" now remove that file and start Synplant up again, register and see if it sticks.

  • Users avatarMike Bosch

    Hi Frederik,

    Thank you for the reply. I have solved the problem by downloading and reinstalling Synplant again and now when I registered it is fine again. I think something must have gone wrong with the upgrade to Mavericks.

    Do you have any idea when you will be releasing a 64 bit version of Synplant? I have used it with Jbridge, but the jbridge windows that constantly opens is really annoying so I just use the 32 bit Ableton version at the moment. (I run both 64 and 32 on the same machine.)

You need to be to post a reply

Sign In / Sign Up


First time here? Just enter your current email and sign up.
×