Bug: Click before playing sound with long attack

Silvio Ecomo646 views2 posts
  • Users avatarSilvio Ecomo

    Hi,

    I emailed your support more than a month ago, along with a patch asking for help.

    No response yet!?

    If i make a bass sound with a slow attack, it will play a click first and then the bass sound plays.

    It's like the slow attack works, but it gives out a click before the attack curve starts.

    Anything you or i can do to fix that?

    Cheers

  • Users avatarMagnus Lidström

    I'm sorry that we haven't answered you earlier. A month is too long to wait. We do try to answer 100% of our emails in a reasonable time, but some months are busier than others, and especially when the question demands some research by me in person, the reply can take a little longer.

    I would say that you have discovered something of a flaw in the Microtonic audio engine. On purpose, the oscillator in Microtonic resets to a phase that gives it a sharp attack. With the attack slider (added in 2.0) you can attenuate this click by raising the attack time. The problem is that the attack curve is not linear, but exponential (this is again on purpose, to enable reverse-sounding drums). A strictly exponentially growing envelope must starts somewhere, so I chose a level that felt good. However, this means that the click can never be fully silenced, regardless of the attack time.

    The phenomena is for natural reasons most obvious with clean low-frequency sounds. The clicks have always been there (since v2.0), but I agree it is not desirable. For the next update I will contemplate adding a secondary linear envelope (on long attack times) to quickly raise the level from -infinite dB. Or maybe make it a full hybrid linear/exp curve, but that might affect existing presets.

    Another thing is that each Microtonic channel is monophonic (as opposed to polyphonic, not stereophonic), and when a voice is re-triggered some clicks should always be expected.

    A simple work-around is to add a noise-gate after Microtonic. If you use Ableton Live, the built-in one will show you the envelope as it plays and you can then clearly see the problem: how the envelope doesn't begin at -infinite dB. Raise the threshold above the initial envelope level (on a maxed out MT sound, put it as high as -20dB).

You need to be to post a reply

Sign In / Sign Up


First time here? Just enter your current email and sign up.
×