Search under Browse for Presets not working

braduro445 views6 posts
  • braduro

    Long standing µTonic and Synplant user.
    I used to be able to pull up the "Browse Patches" or "Browse for Presets" menu option, get a finder pop-up window, and then type in the search field to pull up a subset of results ("(12" for all drum presets in the 120 range, for example). Now the search doesn't result in anything.
    How could I remedy this?

    by default 2015-05-13 at 12.17.16 PM.png
  • Magnus Lidström

    Thanks for the report. I have now verified that this is indeed a problem with our 64-bit builds. I have absolutely no idea why yet. This should be handled entirely by the operating system. But I have found that search works in (at least some) file open dialogs of other plug-ins. So we are doing something differently for sure.

    Will look into it for the next upgrade.

  • braduro

    Some back story: I have a standard (not administrator) user account for my production space, running the latest Yosemite, and my presets are within the root library folder HD>Library>Audio>Presets>Sonic Charge>Microtonic Presets>By Package

    (running the 64-bit version as you correctly deduced)

    And I'm often downloading and saving directly from my production account, saving directly to this folder, if I'm going through the patternarium for example. Some presets will save as mtpreset with a document icon and some as mtpreset but have an exec icon. I confirmed that a sample sub folder and file appear to have full read/write access privileges from this user account.

  • braduro

    Hey Magnus, did you ever chase down this issue? Just checked it.
    So many of the patterns sound good, irregardless of their original tempo, but it does help me to limit my decisions if I can use the search to filter the results...

    So stoked for the PO-32!

  • Magnus Lidström

    Hi! Thanks for reminding me about this. I never did find any solution back then. Asked on Stack Exchange too, but to no avail. Today I discovered that our new standalone version of Microtonic could find .fxb and .fxp files but nothing else, and after some hours of experimentation I have now solved this issue. It seems that Spotlight (responsible for the search box in open dialogs too) doesn't understand the open dialog's file extension filter (e.g. ".mtpreset") unless this file type has been registered by an application in the operating system.

    Fortunately we now have an application, the standalone version of Microtonic, so I added the necessary file type registration information to it today and it solved everything. This will be included in the imminent release of Microtonic 3.2

  • braduro

    Oh that's great news! I finally updated with the purchase of a PO-32, and when I did a Spotlight search, I realized I now had the standalone included from the µTonic installer. I did the BPM (#) search in the presets window, and confirmed that it is working. And then the vst version of the device was able to search for BPM as well, without even restarting the DAW...

You need to be to post a reply

Sign In / Sign Up

First time here? Just enter your current email and sign up.
Facebook sign in no longer available. Use the same email to set password and access your account. If you need help, contact us.