Jimmy Jordan107 views4 posts
  • Jimmy Jordan

    my bit speak went into trial mode on my mac and it won't reset back to being mine. i paid for it and its not wanting to work it says my trial has expired.

  • Fredrik Lidström

    Did you try running the Sonic Charge Authenticator again?

    You can also try entering the manual registration details that you can find on your account page. If it registers manually and works fine but forgets the registration and falls back to trial again when you restart it, then Bitspeek cannot read or write the preference data. This can happen if the access rights on your system has been corrupted. In that case you should first try running the "First Aid" function in Apple Disk Utility.

  • Jimmy Jordan

    i tried running the authenticator and it just took me back to sonic charge

  • Jimmy Jordan

    fixed it

You need to be to post a reply

Sign In / Sign Up

First time here? Just enter your current email and sign up.
Facebook sign in no longer available. Use the same email to set password and access your account. If you need help, contact us.